This project is read-only.

Sawmill Config Help

May 28, 2009 at 2:50 AM

Hey Nate,

I hope you're still reading the posts here.  I really like your program, but I'm having some problems.  I tried to edit the SawMill.exe.config file to display different parameters using codes from logger.xml.  It seems like the program recognizes some of the entries, since it will give me errors about parameters not compatible with my ecu, even though these are basic things like Vehicle Speed (P9).  Other changes to the config file are ignored. 

Any help would be appreciated.

William

Jul 21, 2009 at 9:43 AM

First of all, I'm sorry for the slow response, it's been two months!

It might help to create a log profile using Lumberjack, then copy the parameter IDs and units from the log profile to SawMill.exe.config.  Not all ECUs support all parameters, and Lumberjack will only show parameters that are supported by your ECU.  Try picking the parameters you want using Lumberjack, then save the log profile, then open that in notepad and use that as your reference.  The formats are different, but it should be straightforward to translate:

Lumberjack profile:

  <SerializedColumn>
    <ParameterId>P8</ParameterId>
    <ParameterName>Engine Speed</ParameterName>
    <ConversionUnits>rpm</ConversionUnits>
  </SerializedColumn>

SawMill.exe.config:

  <value>P8,rpm</value>

I'm working now on PLX devices' AFR sensor and OpenPort 2.0 support, when I get those out of the way I'll start on the UI to select parameters from within SawMill.